DRAG DROP (Drag and Drop is not supported)You have a GitHub repository that contains the source code for an app named App1.You need to create process documentation for App1. The solution must include a diagram that displays the relationships between the phases of App1 as shown in the following exhibit.How should you complete the markdown code? To answer, drag the appropriate values to the correct targets. Each value may be used once, more than once, or not at all. You may need to drag the split bar between panes or scroll to view content.Note: Each correct selection is worth one point.Select and Place:
Answer(s): A
Box 1: StateDiagramMermaid can render state diagrams. The syntax tries to be compliant with the syntax used in plantUml as this will make it easier for users to share diagrams between mermaid and plantUml.Note: A state diagram is a type of diagram used in computer science and related fields to describe the behavior of systems. State diagrams require that the system described is composed of a finite number of states; sometimes, this is indeed the case, while at other times this is a reasonable abstraction.Box 2: ProcessingComposite statesIn a real world use of state diagrams you often end up with diagrams that are multi-dimensional as one state can have several internal states. These are called composite states in this terminology.In order to define a composite state you need to use the state keyword followed by an id and the body of the composite state between {}. See the example below:stateDiagram-v2[*] --> First state First {[*] --> second second --> [*]}Note: Mermaid is a Markdown-inspired tool that renders text into diagrams. To create a Mermaid diagram, add Mermaid syntax inside a fenced code block with the mermaid language identifier.Incorrect:* flowchartAll Flowcharts are composed of nodes, the geometric shapes and edges, the arrows or lines. The mermaid code defines the way that these nodes and edges are made and interact.
https://mermaid-js.github.io/mermaid/#/stateDiagram https://mermaid-js.github.io/mermaid/#/flowchart
DRAG DROP (Drag and Drop is not supported)You have a web app named App1 that uses Application Insights in Azure Monitor to store log data. App1 has users in multiple locations.You need to query App1 requests from London and Paris that return a 404 error. The solution must meet the following requirements:Return the timestamp, url, resultCode, and duration fields.Only show requests made during the last hour.How should you complete the query? To answer, drag the appropriate values to the correct targets. Each value may be used once, more than once, or not at all. You may need to drag the split bar between panes or scroll to view content.Note: Each correct selection is worth one point.Select and Place:
Box 1: timestamp >= ago(1hr)Add a time filter to the queryYou can also define your own time range by adding a time filter to the query. It's best to place the time filter immediately after the table name:SecurityEvent| where TimeGenerated > ago(30m)| where toint(Level) >= 10In the preceding time filter, ago(30m) means "30 minutes ago." This query returns records from only the last 30 minutes, which is expressed as, for example, 30m. Other units of time includBox 2: projectUse project and extend to select and compute columnsUse project to select specific columns to include in the results:SecurityEvent| top 10 by TimeGenerated| project TimeGenerated, Computer, Activity
https://learn.microsoft.com/en-us/azure/azure-monitor/logs/get-started-queries
DRAG DROP (Drag and Drop is not supported)You have a web app named App1 that is hosted on multiple servers. App1 uses Application Insights in Azure Monitor.You need to compare the daily CPU usage from the last week for all servers.How should you complete the query? To answer, drag the appropriate values to the correct targets. Each value may be used once, more than once, or not at all. You may need to drag the split bar between panes or scroll to view content.Note: Each correct selection is worth one point.Select and Place:
Box 1: bin(timestamp,1d)Summarizing each day's request count into a timechart (a line chart). We also have options got a bar chart (barchart), pie chart (piechart), area chart (areachart) and scatter chart (scatterchart)requests| summarize request_count = count() by bin(timestamp, 1d)| render timechartBox 2: render (timechart,1d)
https://putridparrot.com/blog/basics-of-kql/
DRAG DROP (Drag and Drop is not supported)You have an Azure subscription that contains multiple users.You need to create an Azure Deployment Environment. The solution must meet the following requirements:Ensure that users can deploy preconfigured environments.Follow the principle of least privilege.Minimize administrative effort.Which four actions should you perform in sequence? To answer, move the appropriate actions from the list of actions to the answer area and arrange them in the correct order.Select and Place:
Configure Azure Deployment EnvironmentsCreate and configure a dev center [Step 2], add a catalog [Step 1] to the dev center, and define an environment type [Step 4]. Then associate a project with the dev center, add environment types, and allow dev access to the project.Step 1: Create a catalogFirst, you create a dev center and attach a catalog to it. The catalog contains the application templates, called environment definitions, that development teams can use to create environments.Step 2: Create a dev centerA dev center is the top-level resource for Azure Deployment Environments that contains the collection of development projects. In the dev center, you specify the common configuration for your projects, such as catalogs with application templates, and the types of environments to which development teams can deploy their code.Step 3: Attach a managed identity to the dev center and assign roles to the identity.Configure a managed identity for the dev centerTo allow the creation of environments, the dev center requires permissions on the subscription. You can attach an identity to the dev center, and then assign the necessary permissions to that identity. You can attach either a system-assigned managed identity or a user-assigned managed identity.Step 4: Create a project environment typeUse an environment type to help you define the different types of environments your development teams can deploy.Note: Configure project environment typesProject environment types are a subset of the environment types configured for a dev center. They help preconfigure the environments that a specific development team can create.In Azure Deployment Environments, environment types that you add to the project are available to developers when they deploy environments. Environment types determine the subscription and identity that are used for those deployments.Project environment types allow platform engineering teams to:* Configure the target subscription in which Azure resources will be created, per environment type and per project.You can provide subscriptions for environment types in a project to automatically apply the right set of policies on environments. This action also abstracts Azure governance-related concepts from your development teams.*-> Preconfigure the managed identity that developers use to perform the deployment, along with the access levels that development teams get after the environment is created.Incorrect:* Create a projectThis would be the next step.
https://learn.microsoft.com/en-us/azure/deployment-environments/quickstart-create-and-configure-devcenter https://learn.microsoft.com/en-us/azure/deployment-environments/how-to-configure-project-environment-types
HOTSPOT (Drag and Drop is not supported)You use Azure DevOps to manage the build and deployment of an app named App1.You have a release pipeline that deploys a virtual machine named VM1.You plan to monitor the release pipeline by using Azure Monitor.You need to create an alert to monitor the performance of VM1. The alert must be triggered when the average CPU usage exceeds 70 percent for five minutes. The alert must calculate the average once every minute.How should you configure the alert rule? To answer, select the appropriate options in the answer area.Note: Each correct selection is worth one point.Hot Area:
Box 1: 5 minutesThe alert must calculate the average once every minute.Note: We [Microsoft] recommend choosing an Aggregation granularity (Period) that is larger than the Frequency of evaluation, to reduce the likelihood of missing the first evaluation of added time seriesBox 2: StaticBox 3: Greater thanExample, say you have an App Service plan for your website. You want to monitor CPU usage on multiple instances running your web site/app. You can do that using a metric alert rule as follows:Target resource: myAppServicePlanMetric: Percentage CPUCondition Type: StaticDimensionsInstance = InstanceName1, InstanceName2Time Aggregation: AveragePeriod: Over the last 5 minsFrequency: 1 minOperator: GreaterThanThreshold: 70Like before, this rule monitors if the average CPU usage for the last 5 minutes exceeds 70%.Aggregation granularity
https://docs.microsoft.com/en-us/azure/azure-monitor/platform/alerts-metric-overview
You have an Azure subscription.You need to ensure that users can provision preconfigured cloud-based environments for developing apps.The solution must minimize administrative effort.What should you include in the solution?
Answer(s): B
Azure Deployment Environments empowers development teams to quickly and easily spin up app infrastructure with project-based templates that establish consistency and best practices while maximizing security. This on-demand access to secure environments accelerates the stages of the software development lifecycle in a compliant and cost-efficient way.A deployment environment is a collection of Azure infrastructure resources defined in a template called an environment definition. Developers can deploy infrastructure defined in the templates in subscriptions where they have access, and build their applications on the infrastructure.
https://learn.microsoft.com/en-us/azure/deployment-environments/overview-what-is-azure-deployment-environments
DRAG DROP (Drag and Drop is not supported)You have an app named App1. You have a Log Analytics workspace named Workspace1 that contains two tables named Events and Logs. App1 manages events in multiple locations and writes logs to Workspace1.You need to query Workspace1 for all log entries related to Asia that occurred during the last two days.In which order should you arrange the query statements? To answer, move all statements from the list of statements to the answer area and arrange them in the correct order.Select and Place:
Step 1: LogsStep 2: | where continent == 'Asia'Step 3: | join ( EventsStep 4: | where timestamp > ago (2d)Step 5: ) on RequestIdExample:Get extended activities from a login that some entries mark as the start and end of an activity.Kusto let Events = MyLogTable | where type=="Event" ;Events| where Name == "Start"| project Name, City, ActivityId, StartTime=timestamp| join (Events| where Name == "Stop"| project StopTime=timestamp, ActivityId)on ActivityId| project City, ActivityId, StartTime, StopTime, Duration = StopTime - St
https://learn.microsoft.com/en-us/azure/data-explorer/kusto/query/joinoperator
You have an Azure subscription that contains a Log Analytics workspace named WS1 and a virtual machine named VM1.You need to install the Microsoft Enterprise Cloud Monitoring extension on VM1.Which two values are required to configure the extension? Each correct answer presents part of the solution.Note: Each correct answer is worth one point.
Answer(s): A,D
To install the Microsoft Enterprise Cloud Monitoring extension on a virtual machine Log Analytics workspace, you can either use the Azure portal or the Azure CLI. The extension, also known as the Log Analytics VM extension, automatically installs and configures the agent, allowing the virtual machine to send data to the Log Analytics workspace.You can use the Azure CLI to deploy the Log Analytics VM extension to an existing virtual machine. The command az vm extension set is used to deploy the extension, with parameters like workspaceId [A] and workspaceKey [D] required. You can find these values in your Log Analytics workspace within the Azure portal.
https://learn.microsoft.com/en-us/azure/virtual-machines/extensions/oms-windows
Share your comments for Microsoft AZ-400 exam with other users:
Question 2:
This is very good and accurate. Explanation is very helpful even thou some are not 100% right but good enough to pass.